
Exercício 5 – parte I 

 

Neste exercício será feita a conversão de dados de CAD para SIG. O processo não é trivial e 
requer que os dados sejam pré e pós processados, o que inclui sua reclassificação e edição. 

Os dados a serem usados são de um cadastro urbano fictício, com quadras e lotes, eixos de vias, 
e árvores, representados por polígonos e linhas, e suas correspondentes toponímias (texto). 

A conversão poderá realizada no próprio ambiente do CAD* com o uso de um programa em 
AutoLISP, especialmente escrito para isso. Há uma tabela de dados de IPTU fictício, em 
formato XLSX (e CSV), para ser agregado aos lotes. 

* são fornecidos os arquivos resultantes de tal conversão para quem não usa o software 
AutoCAD (e para usuários de computadores Macintosh da Apple). 

O objetivo do exercício é o de associar o valor do IPTU de cada lote ao polígono representativo 
do mesmo, o que possibilitará um maior número de análises espaciais do cadastro fictício. 

Baixar os arquivos: 

 Todos: 

• IPTU2021.zip: contém a tabela de dados de IPTU dos lotes – IPTU2021.xlsx / csv 

 Etapa feita no AutoCAD: 

• dxf2mif.zip: contém o programa em LISP – dxf2mif.lsp 
• setor_3.zip: contém o arquivo com a representação do cadastro urbano – 

setor_3.dwg 

 Etapa feita no QGIs para quem não fizer a etapa em CAD: 

• arquivos_mif.zip: contém os arquivos mif/mid, resultantes da execução do 
programa dxf2mif sobre o cadastro urbano setor_3.dwg, no ambiente CAD; 

Esses arquivos devem ser descomprimidos para sua pasta de trabalho. 

Observar que o arquivo dxf2mif.lsp pode ser lido com o uso de um editor de textos simples, 
como o NotePad, ou WordPad no Windows. Ele contém o código fonte programa de conversão, 
em linguagem de programação AutoLisp, e que pode até ser alterado de forma a torná-lo 
melhor. 



(1) 
análise do conteúdo do arquivo Setor3_dwg 

Não usuários de AutoCAD ou usuários de Macintosh – pular este item e o seguinte, e começar 
pelo item (3). 

Abrir o arquivo Setor_3.dwg no programa AutoCAD e analisar o seu conteúdo. Trata-se de um 
arquivo fictício de cadastro urbano, com os layers e objetos correspondentes (completar o 
Quadro 1): 

Quadro 1 – Tipos dos objetos do cadastro urbano fictício em arquivo DWG 

layer conteúdo representação 

0   
URB-ARV árvores Block Reference 

URB-LOT-POL lotes 
Polyline (closed), com trechos em arco de 
circunferência 

URB-LOT-COD toponímia dos lotes Text 
URB-QUA-POL quadras  
URB-QUA-COD toponímia das quadras  
URB-VIA-EXO eixos das ruas  
URB-VIA-NOM toponímia das ruas  

 

Observar pela janela Properties que os block references das árvores contém attributes. 
Completar o Quadro 2 com os nomes dos attributes e os tipos de dados que podem ser inferidos 
a partir dos seus valores. 

Quadro 2 – Lista de attributes dos block references das árvores 

attribute ex. Valor tipo de dado 

ESPECIE Ipê Roxo Texto (String) 
   
   
   

 

Também se pode inferir alguns relacionamentos entre os domínios espaciais dos objetos, 
conforme indicado no Quadro 3. 

Quadro 3 - Relacionamentos espaciais observados entre os tipos de objetos do cadastro 

tipo 1 relacionamento espacial tipo 2 

Quadras Contém Lotes 
Quadras Contém Toponímia das quadras 
Quadras Contém Árvores 
Lotes Contém Toponímia de lotes 
Eixos das ruas Contém** Toponímia das ruas 

** Não tão óbvio 

 



(2) 

uso do programa dxf2mif.lsp – conversão dos dados 

Carregar o programa (Load Application) dxf2mif no programa AutoCAD; em seguida executá-
lo, apenas digitando o seu nome na Command Line. Se não for exibida mensagem de erro, a 
operação de conversão foi provavelmente bem sucedida. 

Observar o conteúdo na sua pasta de trabalho. Devem ter sido gravados novos arquivos, com as 
extensões MIF e MID (diferentemente do que pensa o Windows não se trata de arquivo 
multimídia). Trata-se dos pares de arquivos conforme o MapInfo Interchange Format, os quais 
podem ser abertos com um editor de textos simples. 

O Quadro 4 exibe seus conteúdos, o que pode ser visualizado com um editor de têxtis simples. 

Quadro 4 – conteúdos dos arquivos MIF/MID gerados pelo programa dxf2mif 

nome MIF MID 

linhas 
cabeçalho com metadados e coordenadas dos 
extremos das linhas (segmentos de reta: lines) 

dados alfanuméricos, 
conforme o cabeçalho do 
MIF correspondente 

plines 
cabeçalho com metadados – apenas 
(sem dado algum) 

sem dado algum (vazio) 

pontos 
cabeçalho com metadados e coordenadas de 
pontos (point ou text) 

dados alfanuméricos, 
conforme o cabeçalho do 
MIF correspondente 

regions 
cabeçalho com metadados e coordenadas de 
vértices de polígonos (closed polylines) 

dados alfanuméricos, 
conforme o cabeçalho do 
MIF correspondente 

 

Completar o Quadro 5, indicando as correspondências entre os dados em CAD do arquivo 
setor_3.dwg e os arquivos gerados pelo programa dxf2mif. 

Quadro 5 – correspondências entre tipos de objetos CAD e SIG 

Layer CAD Objeto 
CAD 

Arquivo 
SIG 

handle camada cota(_ini) [valor] [cota_fim] 

URB-ARV Block 
Reference 

*** 

URB-
LOT_POL 

Pline 
(closed) 

regions sim 
URB-
LOT_POL 

sim n.s.a. n.s.a. 

URB-LOT-
COD 

Text pontos sim 
URB-
LOT-COD 

sim toponímia n.s.a. 

URB-QUA-
POL 

       

URB-QUA-
COD 

       

URB-VIA-
EXO 

       

URB-VIA-
NOM 

       

 

*** Os block references das árvores não possuem correspondentes nos arquivos gerados, por 
não ser tratado pelo programa dxf2mif. A extração dos dados de block references (as árvores) é 
feita, diretamente com o uso do software AutoCAD, na parte II do exercício. 



Observa-se que cada par de arquivos MIF/MID gerado pode conter mais de um tipo de 
elemento, originalmente em layers diferentes em CAD. Os objetos são gravados nesses 
arquivos, conforme sua representação espacial: polígono, polilinha, linha (segmento de reta), ou 
point (ponto ou ponto de inserção de texto). 

(3) 
Referenciamento dos dados no QGis 

Criar um novo projeto, AUT5826 – Exercicio 5, na pasta de trabalho, para os arquivos mif/mid 
gerados pelo programa dxf2mif, exceto o plines (que está sem dado algum). 

Atribuir ao novo Projeto o sistema de coordenadas WGS84 / UTM 23S [EPSG:32723], cuja 
Unidade é Meters. 

Layer > Add Layer > Add Vector Layer 

 Navegar até a pasta dos arquivos mif/mid gerados e carregar um a um: linhas.mif (e 
mid), pontos.mif (e mid) e regions.mif (e mid). 

Basta selecionar o arquivo MIF 

Verificar se o Encoding está como Windows-1252 (Windows Latin extended). 

Como os cabeçalhos dos arquivos mif gerados não indica sistema de coordenadas, o 
QGis tende atribui-la, em geral Lat/Long e Datum WGS84. 

Ao carregar, ou após carregar, cada camada, indicar o sistema de coordenadas correto, 
ou seja, WGS84 / UTM 23S [EPSG:32723]. 

Após carregar cada camada, usar a tabela de atributos para ver o resultado e também verificar se 
os tipos de dados estão corretos 

pontos > Properties > Fields 
handle Text (string) String id 
camada Text (string) String camada no arquivo dwg 
cota Decimal (double) Real cota z 
valor Text (string) String toponímia associada ao ponto 

linhas > Properties > Fields 
handle Text (string) String id 
camada Text (string) String camada no arquivo dwg 
cota_ini Decimal (double) Real cota z do extremo inicial 
cota_fim Decimal (double) Real cota z do extremo final 

regions > Properties > Fields 
handle Text (string) String id 
camada Text (string) String camada no arquivo dwg 
cota Decimal (double) Real cota z 

Verificar também as tabelas de dados, em especial, a da camada pontos que contém toda a 
toponímia do cadastro. Ocorre que os nomes das ruas estão sem acentuação. 



(4) 

Reclassificação e conversão dos dados 

Os diferentes tipos de objeto do cadastro urbano devem ser separados em Planos diferentes dos 
carregados, após o qual poderão ser descartados do Projeto. 

Além disso, o formato MIF/MID se presta a transferência de dados, de um software para outro, 
e não ao seu processamento, portanto há de se salvar cada camada num GeoPackage, 
Exercicio_5. 

Fazer a separação com base na coluna Camada, salvando no GeoPackage e nomeando cada 
nova camada com o nome da camada correspondente, por exemplo, da tabela acima a camada 
mif/mid regions contém quadras e lotes que devem dar origem às novas camadas 

URB_QUA_POL e URB_LOT_POL, no GeoPackage. 

(4.1) 
Reclassificação e conversão de dados do tipo point. 

(4.1.1) 
Na lista de camadas, apontar pontos 
Na barra de ferramentas acionar [Select Features By Value] 

Camada: URB-LOT-COD [Equal to] 

[Select Features] e [Close] 

Exportar apenas os dados Selecionados para o GeoPackage Exercicio_5, com o nome 
URB-LOT-COD 

Verificar que o Encoding e o Sistema de Coordenadas estejam corretos, e 
também que a indexação espacial ocorra no banco de dados GeoPackage. 

Habilitar a adição da nova camada ao Projeto, que deve ser salvo a cada 
alteração. 

(4.1.2) 
Ainda apontando para a camada pontos deselecionar o que havia selecionado 
anteriormente [Deselect Features...], e repetir o procedimento anterior para 

Camada: URB-QUA-COD [Equal to] 

[Select Features] e [Close] 

Exportar apenas os dados Selecionados para o GeoPackage, com o nome 
URB-QUA-COD 

(4.1.3) 
Repetir os passos acima para URB-VIA-NOM. 



(4.2) 
Reclassificação e conversão de dados do tipo polygon. 

(4.2.1) 
Apontar para a camada regions da lista. 

Repetir o procedimento para as camadas URB-QUA-POL e URB-LOT-POL. 

(4.3) 
Conversão das linhas. 

Exportar a totalidade das linhas para a camada URB-VIA-EXO, do GeoPackage, por não haver 
dados a separar em outras camadas. 

(4.4) 
Após terem sido feitas as separações, remover do projeto os arquivos MIF/MID. 

Alterar as cores para a visualização assim como a ordem de exibição das camadas, em especial, 
os lotes sobre as quadras e as linhas e os pontos sobre esses. 

Salvar o Projeto. 

(5) 

Operações geográficas e alfanuméricas 

Observar os valores da coluna valor das camadas URB-QUA-COD e URB-LOT-COD. 

Na camada URB-QUA-COD a coluna de dados valor contém os caracteres “SQ” seguido de 6 
dígitos numéricos. Trata-se de variável do tipo Text (String). 

Na camada URB_LOT_COD a coluna de dados valor contém dois dígitos numéricos em 
formato Texto (String). 

Os valores acima, quando concatenados, correspondem ao campo SQLF da tabela, faltando 
apenas o prefixo SQ. 

São necessárias algumas operações geográficas, de bancos de dados e de manipulação de texto 
(string) para: 

• capturar os códigos das camadas associadas a pontos de quadras e lotes e associá-los 
aos seus correspondentes polígonos – conforme indicado na Figura 1; 

• transferir os códigos de cada polígono de quadra para os lotes nela contidos - conforme 
indicado na Figura 2; 

• efetuar a concatenação e enquanto se elimina o prefixo SQ – também indicado na 
Figura 2; 

• importar os dados da tabela IPTU2021.csv; e efetuar seu cruzamento com a camada de 
lotes – conforme indicado na Figura 2. 



Figura 1 
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(5.1) 
Capturar os códigos das quadras (toponímia) nas respectivas quadras (polígonos), conforme 
indicado na parte superior da Figura 1. 

Vector > Data Management Tools > Join Attributes by Location 
 Join to features in URB-QUA-POL [EPSG:32723] 
 Features they (geometric predicate) [v] contain 
 By comparing to URB-QUA-COD [EPSG:32723] 
 Fields to Add: […] e selecionar apenas [v] valor 
 Joined Fields Prefix: SQ_ 
 Join Type: Take attributes from the first located feature only (one-to-one) 
 [  ] Discard records that could not be joined –  
  para preservar quadras sem toponímia (não é o caso) 
 Joined layer: [...] – salvar no GeoPackage, como URB-QUA-SQ 
 [ v ] open output file after running algorithm 
 [Run] e [Close] 

Se durante o processamento, for exibida uma mensagem da nova camada não ter 

indexação espacial, proceder como segue. 

  URB-QUA-SQ > Properties > Source 

  Geometry 

   [Create Spatial Index] 

O arquivo deve ter sido gerado. Abrir e verificar seu conteúdo (em especial a nova coluna 

SQ_valor com a toponímia capturada), após o qual as camadas URB-QUA-POL e URB-

QUA-COD podem ser removidos do Projeto. 

Salvar o Projeto. 

(5.2) 
Capturar os códigos dos lotes (toponímia) nos respectivos lotes (polígonos), conforme indicado 
na parte inferior da Figura 1. 

Fazer o mesmo para os polígonos dos lotes em URB-LOT-POL, capturando a toponímia em 

URB-LOT-COD e gerar a camada URB-LOT-L com a nova coluna L_valor. 

Se durante o processamento, for exibida uma mensagem da nova camada não ter 

indexação espacial, proceder como segue. 

  URB-LOT-L > Properties > Source 

  Geometry 

   [Create Spatial Index] 

Verificar o conteúdo dessa camada, remover do Projeto as camadas URB-LOT-POL e 

URB_LOT_COD  

Salvar o Projeto. 



Figura 2 

 

(5.3) 

Há de se distribuir os códigos dos polígonos das quadras para os dos lotes (conforme indicado 

na Figura 2), de modo que possam ser posteriormente concatenados para cruzar com os dados 

da tabela IPTU2021. 

Vector > Data Management Tools > Join Attributes by Location 
 Join to features in URB-LOT-L 
 Features they (geometric predicate) [v] are within 
 By comparing to URB-QUA-SQ 
 Fields to Add: […] e selecionar apenas [v] SQ_valor 
 Joined Fiels Prefix: 
 Join Type: Take attributes from the first located feature only (one-to-one) 
 [  ] Discard records that could not be joined –  
  para preservar lotes fora de quadras (não é o caso!) 
 Joined layer: [...] – salvar no GeoPackage como URB-LOT-SQL 
 [v] open output file after running algorithm 
 [ Run ] e [ Close ] 

Se durante o processamento, for exibida uma mensagem da nova camada não ter 

indexação espacial, proceder como segue. 

  URB-LOT-SQL > Properties > Source 

  Geometry 

   [Create Spatial Index] 

Verificar o conteúdo (em especial a nova coluna SQ_valor com a toponímia capturada), 

após o qual as camadas URB-LOT-L e URB-QUA-SQ pode ser removido do Projeto. 

Salvar o Projeto! 
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(5.4) 

Criar um novo campo do tipo Texto (String) na tabela da camada URB-LOT-SQL (conforme 

indicado na Figura 2), de nome SQLF, tamanho 8, no Field Calculator com a expressão: 

 concat( right( “SQ_valor”, 6 ) ,”L_valor” ) 

Verificar o Output preview, o qual deve estar mostrando o resultado para uma das 

linhas da nova coluna, por exemplo ‘08700325’. 

[OK] e [Close] 

Ao aplicar a função right(   ) com os argumentos SQ_valor e 6, essa função retorna 
apenas os seis caracteres da porção direita desse campo. A função concat(   ) faz a 
concatenação desses 6 caracteres com os 2 caracteres do campo L_valor, formando o 
conteúdo do campo SQLF. 

O novo campo SQLF dos lotes em URB-LOT-SQL que acaba de ser instanciado pode ser usado 
como elemento de ligação com a tabela IPTU2021. Podem ser feitas análises espaciais 
envolvendo dados dos lotes, quadras, valores de IPTU, etc. 

(5.5) 
Carregar a tabela de IPTU do arquivo IPTU2021.xlsx no GeoPackage. 

Verificar os dados carregados. 

Figura 3 

 

(5.6) 
Cruzar a tabela de dados da camada URB-LOT-SQL com a tabela de IPTU (conforme indicado 
na Figura 3) 

Database > DB Manager > GeoPackage � Exercicio_5 
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 SQL – montar a expressão para atrelar os valores de AC (área construída) e de IPTU 
(IPTU anual em 2021) aos lotes 

 SELECT "URB-LOT-SQL"."geom", 
 "URB-LOT-SQL"."handle", 
 "URB-LOT-SQL"."cota", 
 "URB-LOT-SQL"."SQLF", 
 "IPTU2021"."AC", 
 "IPTU2021"."IPTU" 
 FROM "URB-LOT-SQL", "IPTU2021" 
 WHERE "URB-LOT-SQL"."SQLF" = "IPTU2021"."SQLF" 

Salvar camada resultante no GeoPackage como URB-LOT-SQL-IPTU2021. 

Após verificar o conteúdo da nova camada, a camada URB-LOT-SQL, a camada virtual, e a 
tabela IPTU2021 podem ser removidas do Projeto. 

Permanecem, referidas no Projeto****, as camadas: 
 URB-VIA-NOM 
 URB-VIA-EXO 
 URB-LOT-SQL-IPTU2021 
 URB-QUA-CO 

 **** que, entretanto, não foram removidas do banco de dados. 

Continua no ... 

Exercício 5 - parte 2 - contém as operações para converter os block references das árvores do 
arquivo setor_3.dwg em objetos SIG, e carrega-los no banco de dados do cadastro. 


